Logo for the programming language, PHP
News , ,

Increased Minimum PHP Version in QSM 6.0

As long as Quiz And Survey Master (QSM) has existed, the plugin has always supported PHP versions 5.2 and 5.3. However, when QSM first launched, 5.2 had already stopped receiving security updates and PHP was ending support of 5.3 in a few months.

Before we jump into the why and how, I wanted to quickly define what PHP is for those they may be unfamiliar. WordPress is built in a programming language called PHP. PHP is run on the server that hosts your website and is normally run with a program such as Apache or Nginx.

Over time, this programming language receives updates to fix security issues, improve performance, and add new features. For example, PHP 7.1 is estimated to be between 7 and 13 times faster than PHP 5.2 depending on the site.

Why Are We Changing The Minimum?

Now, PHP 5.2 has not received security updates in almost 7 years and PHP 5.3 has not received any in 3 years. These versions are also noticeably slower than more recent versions. The most recent version is PHP 7.2 which is 7 major updates after 5.2. Since this plugin has always supported 5.2, it has meant that we could never take advantage of newer features of PHP including features that would be much more efficient.

Recently, WordPress has started allowing plugins to designate a minimum version of PHP that the plugin will support. If a site is using an older version than the plugin supports, WordPress will not install the plugin. Or, if a plugin increases the minimum, then that site will no longer receive updates until the site updates its version of PHP.

While versions 5.2, 5.3, 5.4, 5.5, and 5.6 are all no longer receiving active support and only 5.6 still receiving security updates, we are only dropping support for PHP 5.2 and 5.3. Many users have been generous in allowing QSM to send some site data to us which helps in making these decisions.

Pie chart showing PHP versions in QSM plugin with PHP 5.2 being a very small percentange

In the pie chart above, PHP 5.2 is the tiny pink part which accounts for less than 1% of all sites using QSM. PHP 5.3 is the dark brown which has around 4% of all sites. So, this change will only affect around 5% of users of this plugin. While we would like to end support for PHP 5.4 to begin using many of the newer features introduced in PHP 5.5, PHP 5.4 is used on 13.1% of all sites using QSM so we decided to only end support for 5.2 and 5.3 for now.

Starting in version 6.0 of QSM (scheduled for March 2018), this plugin will require PHP 5.4 or newer.  If your site is using a version of PHP less than 5.4, the plugin and its addons will continue to work on your site. However, you will no longer receive updates until you update your version of PHP.

What Do You Need To Do?

Starting in QSM version 5.2 (scheduled for early January 2018), a small banner will appear in the WordPress admin when creating or editing your quizzes that will alert you if your site is using PHP 5.2 or 5.3. You can also use a plugin such as the free “My WordPress Health Check” plugin which tells you the version of PHP your site is using.

If your site is using PHP 5.2 or 5.3, you must contact your hosting provider in order to ask them about updating your PHP version. If you do not update, your quizzes and surveys will continue to work. However, you will no longer receive future updates for QSM or its addons until you update the site’s version of PHP.

If your site is already using PHP 5.4 or newer, there is nothing you need to do! Everything will continue to work the same as it always has.

Featured Photo by Jinho.Jung

Leave a Reply

Your email address will not be published. Required fields are marked *